Un utente ha chiesto informazioni su WooCommerce di Wordpress

le immagini non verranno visualizzate dopo l’aggiornamento a Woo 3.3.3

Un utente ha chiesto 👇

Dopo aver aggiornato Woo Commerce alla v3.3.3, ho una domanda che le immagini dei prodotti non vengono visualizzate quando visualizzi una pagina che presenta una serie di prodotti per categoria. Ecco alcuni suggerimenti che ho notato, ma non mi sembra di prestare attenzione all’origine del problema:

se visualizzate sulla pagina dall’interno del Cliente in un weekend di WordPress, le immagini si mostrano perfettamente se guardi la pagina dal davanti, le immagini appaiono nel codice sorgente con le dimensioni corrette, ma quando “esplori” sulle immagini in Firefox o Chrome, quando si passa al codice sorgente dell’immagine e all’elemento Div che contiene, il popup nero mostrato nella pagina mostrata mostra un’altezza di “0”. il sito utilizza un tema figlio di Flatsome – se passo a un tema diretto di Flatsome, le immagini mostrano; ma se rimuovo tutto dalla cartella del tema figlio (non molto) solo un foglio di stile vuoto con le informazioni di intestazione. e ritorno al child theme, il problema si ripresenta Quando l’immagine viene esplorata in Firefox, se seleziono il codice sorgente dell’immagine e esco dal div esistente, l’immagine viene visualizzata. Ma quando esploro il div contenente non riesco a vedere alcuna regola CSS che potrebbe dargli un’altezza di 0 o altrimenti causare qualsiasi immagine all’interno non mostrerebbe il modello di woo per le pagine che hanno il problema tassonomia-product_cat.php

Sto lottando molto per scoprire cosa sta causando questo problema. Eventuali intuizioni o idee sarebbero i benvenuti, grazie. Non crederai a quanto tempo ho passato a cercare di risolverlo.

ps la pagina in questione è protetta da pword per impedire a Google di indicizzarla – per visualizzarla usa “wp” e “guest” per uname e pword.

Questo argomento è stato modificato 3 anni, 1 mese fa da. Questo argomento è stato modificato 3 anni, 1 mese fa da.

Supporto per plugin

(@lindamork)

Ingegnere automatizzato della felicità

3 anni, 1 mese fa

Ciao,

Per favore controlla la tua versione di Flatsome in quanto sembra che ti suggeriscano di aggiornare alla versione 3.5.2 se hai problemi con le immagini durante la descrizione.

Puoi controllare il rapporto sullo stato del sistema tramite la dashboard qui: WooCommerce> Stato. Scorri verso il basso fino alla sezione Modello nella parte inferiore del rapporto e verifica la presenza di file modello obsoleti. Puoi leggere come aggiornare i modelli qui:
https://docs.woocommerce.com/document/fix-outdated-templates-woocommerce/

Lanciatore di thread

(@megunticook)

3 anni, 1 mese fa

Grazie per i vostri suggerimenti. Ho installato Flatsome v 3.5.2 e tutti i file modello sembrano andare bene (Stato WooCommerce> non ha bandiere rosse).

Ciò che mi ha fatto davvero grattarmi la testa è che le immagini vengono visualizzate quando visualizzo l’anteprima della pagina nella personalizzazione posteriore, ma non vengono visualizzate quando la pagina viene visualizzata di fronte. La pagina non ha lo stesso codice in entrambi i posti? Sembra che se riuscissi a capire come l’ambiente di anteprima del weekend sia diverso da quello iniziale, potrei trovare e correggere il problema.

Sembra che ci debba essere una regola CSS da qualche parte, ma quando ho rimosso tutto il CSS aggiunto nella personalizzazione, il problema non è andato via.

Cosa mi manca qui?

(@icaleb)

Ingegnere automatizzato della felicità

3 anni, 1 mese fa

Nella personalizzazione, alcune immagini visibili automaticamente vengono rigenerate per mostrare e mostrare le impostazioni dell’immagine.

Sembra che tu possa disabilitare la rigenerazione dell’immagine. Prova questo plugin per rigenerare tutto in una volta: https://wordpress.org/plugins/regenerate-thumbnails/

Lanciatore di thread

(@megunticook)

3 anni fa

Grazie – Ho rigenerato tutte le immagini utilizzando WP-CLI che dovrebbe essere più veloce ma non ha risolto il problema.

Deve esserci qualcosa in quel child theme che causa questo, ma per il resto della mia vita non riesco a capire cosa sia.

Ancora non capisco perché tutto sembra fantastico quando viene visualizzato attraverso la personalizzazione, ma non nel front-end.

Ecco un’immagine di ciò che vedo quando esploro l’immagine: nota come il riquadro nero sopra mostra dove l’altezza dell’immagine sarebbe “o” anche se l’immagine stessa mostra un’altezza di 296 nel markup html. Quale potrebbe essere un pasticcio con l’altezza qui?

Questa risposta è stata modificata 3 anni fa da. Questa risposta è stata modificata 3 anni fa da. Questa risposta è stata modificata 3 anni fa da. Questa risposta è stata modificata 3 anni fa da. Questa risposta è stata modificata 3 anni fa da.

(@icaleb)

Ingegnere automatizzato della felicità

3 anni fa

Dev’essere qualcosa nel tema figlio, oppure il tema principale sta facendo alcune cose che non sono impostate correttamente per funzionare con un tema figlio tecnicamente fattibile.

Lanciatore di thread

(@megunticook)

3 anni fa

Ho restituito tutte le personalizzazioni per impostazione predefinita nel tema figlio, le immagini erano visibili. Ho provato a ricreare le personalizzazioni una per una, ma le immagini non sono riuscite a scomparire. Questo è Flatsome Theme, che ha una funzione “UX builder”, penso che ci sia qualcosa che si è rotto quando ho installato l’ultimo WooCommerce. Vedrò se riesco a esprimerlo.

Amico, questo è un tale inganno!

(@icaleb)

Ingegnere automatizzato della felicità

3 anni fa

Be ‘, però, è una costrizione. Sicuramente un tema per tuo figlio. Segnalo come una soluzione, ma se trovi un bug o qualcosa nel cuore di WooCommerce, sentiti libero di aprire un nuovo thread.

Lanciatore di thread

(@megunticook)

3 anni fa

I temi UX hanno rilasciato un altro aggiornamento al tema Flatsome oggi e il problema è stato risolto.

Ho completato la mia giornata, grazie per il tuo aiuto. Ho provato a contattarli alcune settimane fa per porre domande sulla domanda ma non ho ottenuto risposta. Immagino che ne fossero consapevoli e se ne siano presi cura.

Phew!

Grazie per l’aiuto.

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *