Un utente ha chiesto informazioni su WooCommerce di Wordpress

Le immagini della galleria del prodotto vengono visualizzate dietro l’immagine principale del prodotto

Un utente ha chiesto 👇

Riepilogo dei problemi

Il problema è con i prodotti che hanno un’immagine principale del prodotto e le immagini nella galleria del prodotto. Quando guardi un archivio / galleria di prodotti, puoi vedere l’immagine principale e una delle immagini della galleria una sopra l’altra. Sopra l’immagine include l’immagine principale e l’immagine della galleria è mostrata sotto.

Quando c’è solo un’immagine principale e nessuna immagine della galleria, l’immagine del prodotto è più piccola e non cambia quando ci si ripassa.

Acquisizione video del problema
Schermata di un singolo prodotto con immagini della galleria

In questo video, puoi prima vedere che un MP3 ha un’immagine più grande e, quando lo guardo, vedi un’immagine diversa. Tutte le immagini MP3 hanno esattamente le stesse dimensioni e il tipo di immagine (600 × 600 jpg). In quello più grande e mutevole, ho aggiunto un’immagine diversa (e non correlata) nella galleria del prodotto (vedi foto collegata sopra).

Successivamente nel video, puoi vedere che, nel caso delle tazze, sono visibili due maniglie. Le tazze sono disponibili in due diverse dimensioni (11 once e 15 once), quindi uso la galleria in quel caso.

La galleria / archivio del prodotto dovrebbe visualizzare solo l’immagine principale del prodotto, anche durante la ricerca. Le immagini della galleria dovrebbero apparire solo sulla pagina del singolo prodotto.

Sforzi di risoluzione

1. Aggiornato all’ultima versione di WordPress, tema e tutti i plugin
2. Disattiva tutti i plugin eccetto WooCommerce ed Elementor
Nota: tutte le mie pagine di servizi igienici sono costruite utilizzando Elementor Pro, quindi uccide la disattivazione del sito e non vedi la galleria del prodotto.
3. Modificare i temi in Twenty Twenty
4. Cancella tutte le cache (sito, browser, ecc.)

Risultati: si è verificato un problema in tutti i casi.

A questo punto non sono sicuro di cosa lo causi o come risolverlo.

Questo argomento è stato modificato l’ultima volta 6 mesi fa da. Motivo: rendi il titolo più chiaro

Supporto per plugin

(@laceyrod)

Ingegnere della felicità di Automattic

6 mesi fa

Ciao,

Grazie per il contatto! Ho dato un’occhiata al video che hai fornito e vedo sicuramente il comportamento che stai segnalando. Molto strano!

Sembra che tu abbia compiuto ogni passo che normalmente consigliamo in questo caso testando i conflitti. Poiché il problema con solo WooCommerce ed Elementor rimane attivo e ti affidi a Elementor per strutturare le tue pagine, consiglierei davvero di contattarli direttamente per vedere se qualcosa sta funzionando con il loro page builder. Questo non è qualcosa che possiamo riprodurre su un’installazione predefinita con solo Twenty Twenty e WooCommerce attivi, quindi non sarei sorpreso se qualcosa andasse storto con il plug-in Elementor che causa questo comportamento.

Contatta direttamente il loro team e speriamo di indicarti la giusta direzione!

Lanciatore di thread

(@jrothra)

6 mesi fa

Se ottengo una soluzione da Elementor, la posterò qui nel caso in cui anche altre persone abbiano questo problema.

Lanciatore di thread

(@jrothra)

5 mesi, 4 settimane fa

Ho parlato con il supporto di Elementor ed ecco la soluzione:

Vai alle impostazioni di WooCommerce in Customizer e modifica lo stile del prodotto e le impostazioni di visualizzazione dell’immagine:

Aspetto> Personalizza> WooCommerce> Archivi
Imposta “Stile prodotto” su “Predefinito”
Imposta “Product Entry Media” su “Immagine in primo piano”

Per me, lo stile era già impostato per impostazione predefinita, ma Media era impostato su Hover. L’ho cambiato e ho risolto il problema!

(@mmmn)

2 settimane, 4 giorni fa

Ciao, all’inizio ho un problema simile con jrotha:

“Quando guardi un archivio / galleria di prodotti, puoi vedere l’immagine principale e una delle immagini della galleria una sopra l’altra. Sopra l’immagine include l’immagine principale e l’immagine della galleria è mostrata sotto. “

Ciò pone problemi particolari nella versione mobile. Ho anche attraversato tutte le fasi di risoluzione dei problemi come ha fatto jrotha, incl

Aspetto> Personalizza> WooCommerce> Archivi
Imposta “Stile prodotto” su “Predefinito”
Imposta “Product Entry Media” su “Immagine in primo piano”

Tuttavia, questo non ha cambiato nulla e il problema persiste. C’è qualche altro approccio per risolvere questo problema?

Grazie in anticipo!

Supporto per plugin

(@laceyrod)

Ingegnere della felicità di Automattic

2 settimane, 2 giorni fa

Ciao @mmmn –

Stai usando anche Elementor?

In tal caso, contatta il loro team per uno sguardo più attento.

Se il tuo problema è con un tema predefinito e solo con il core di WooCommerce, apri un nuovo thread in modo che possiamo guardare lì.

Saluti.

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *