Un utente ha chiesto informazioni su WooCommerce Square di Wordpress

Errori di elaborazione quadrati ogni 30 giorni?

Un utente ha chiesto 👇

Circa un mese fa, mi sono imbattuto in uno dei miei primi errori di pagamento quando un cliente ha provato a controllare. È stato fornito il seguente errore “Errore: Square non è stato in grado di completare la transazione. Riprova più tardi o utilizza un altro metodo di pagamento. “Non ho ricevuto alcun preavviso in merito al problema, né abbiamo apportato modifiche / aggiornamenti al sito / tema o ai plug-in.

Dopo alcune ricerche, ho scoperto che il problema del pagamento è stato risolto scollegando Square da Woocommerce e autorizzando nuovamente il sito con Square. L’ho trasformato in un incidente remoto, fino a stasera quando è successo di nuovo. Sono stato in grado di disconnettere / ricollegare il sito a Square e i pagamenti ora funzionano di nuovo.

Qualcuno sa perché sta accadendo e cosa posso fare per risolverlo in modo permanente? Ho provato a sincronizzare l’inventario / ecc senza successo.

Grazie

Supporto per plugin

(@grigaswp)

1 anno, 4 mesi fa

Ciao,

Grazie per il contatto!

Capisco che i pagamenti tramite Square a volte falliscono con “Errore: Square non è stato in grado di completare la transazione. Riprova più tardi o utilizza un altro messaggio per utilizzare il pagamento. “E aiuta a ricollegare il tuo sito a Square.

Quale versione di Square stai usando? Nelle versioni precedenti alla 2.0.5 di Square per WooCommerce, c’era un bug che causava la disconnessione automatica dei siti da Square ogni tanto. Ogni volta che ciò accade, tutti i pagamenti iniziano a fallire.

Token: se abiliti la registrazione del debug in WooCommerce >> Impostazioni >> Pagamenti >> Square, ogni volta che ciò accade, vedrai questo errore nei log degli errori Square in WooCommerce >> Stato >> Log:

> Impossibile rinnovare il collegamento: Impossibile rinnovare il segnale! valore non valido per il parametro access_token

Questo dovrebbe essere aggiornato aggiornando alla versione più recente, anche se ti faremo sapere se questo sta ancora accadendo con l’ultima versione del plug-in Square per WooCommerce.

Lanciatore di thread

(@flynnstone)

1 anno, 4 mesi fa

Stiamo ancora eseguendo il plugin 1.0.38. Ero riluttante ad aggiornare a causa del numero di problemi segnalati dalle persone su 2.xxx

Non ho visto nemmeno quell’errore di segnalazione nei nostri log di debug. Credo che abbia detto che si trattava di un “errore sconosciuto”

Questa risposta è stata modificata 1 anno, 4 mesi fa. Supporto per plugin

(@grigaswp)

1 anno, 4 mesi fa

Ciao,

Stiamo ancora eseguendo il plugin 1.0.38. Ero riluttante ad aggiornare a causa del numero di problemi segnalati dalle persone su 2.xxx

Non ho visto nemmeno quell’errore di segnalazione nei nostri log di debug. Credo che abbia detto che si trattava di un “errore sconosciuto”

Grazie per la conferma! In effetti, la versione 2.0.0 di Square per WooCommerce è stata una riscrittura completa con alcune modifiche alle funzionalità fornite con alcuni bug.

Le versioni aggiuntive (dalla 2.0.1 alla 2.0.7) contengono principalmente correzioni di bug, quindi la versione 2.0.7 è molto più stabile della 2.0.0 iniziale.

A questo punto, poiché la versione 1.0.38 non funziona più, consiglierei di provare l’ultima versione di Square su un sito stage e quindi aggiornarla sul sito live.

Se non hai un sito stage, puoi crearne uno con un plugin come WP Staging:

WP STAGING – Backup Duplicator & Migration

Si noti inoltre che la struttura del prodotto cambia dopo l’aggiornamento a 2.x, quindi il downgrade alla 1.0.38 dopo l’aggiornamento non è consigliato.

Spero che possa aiutare!

Lanciatore di thread

(@flynnstone)

1 anno, 4 mesi fa

Grazie! Se riscontro problemi dopo l’aggiornamento alla 2.0.7, potrò tornare alla 1.0.38? So che hai detto che non ti è consigliato di tornare indietro a causa di cambiamenti nella struttura del prodotto, ma sono preoccupato per il trasferimento senza una via d’uscita. La disconnessione della funzione di sincronizzazione del prodotto nella 2.0.7 aiuterà il downgrade per problemi?

Supporto per plugin

(@grigaswp)

1 anno, 4 mesi fa

Ciao,

Grazie! Se riscontro problemi dopo l’aggiornamento alla 2.0.7, potrò tornare alla 1.0.38?

Se aggiorni il plug-in Square al sito live, ti consiglio di non eseguire il downgrade a 1.0.38 in un secondo momento.

Se provi l’aggiornamento al tuo sito stage con la sincronizzazione del prodotto disabilitata, ciò non dovrebbe influire sul tuo sito live, quindi potresti decidere di non aggiornare il sito live in un secondo momento.

Spero che possa aiutare!

Supporto per plugin

(@grigaswp)

1 anno, 3 mesi fa

Ciao,

Non ti sentiamo da un po ‘, quindi contrassegnerò questo thread come risolto.

Tuttavia, non esitare ad aprire una nuova discussione e collegarti a questa se hai ulteriori domande.

Buona giornata!

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *