Un utente ha chiesto informazioni su WooCommerce Side Cart (Ajax) di Wordpress

Funzione integrale WC () -> cart-> get_item_data

Un utente ha chiesto 👇

Sostituisci WC () -> cart-> get_item_data wc_get_formatted_cart_item_data in side-cart-woocommerce / public / partials / xoo-wsc-content.php.

La funzione WC () -> cart-> get_item_data non è deprecata dalla versione 3.3 di Woocommerce.

Grazie

(@cmcsweeney)

2 anni, 9 mesi fa

Ho la stessa domanda.

L’errore nel file error_log è il seguente:

Funzione WC_Cart :: get_item_data non mostrata dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data.

Non sembra avere un effetto casuale sul sito, ma quando lo fa, ottengo una pagina vuota con un errore “Questa pagina non funziona” (in Chrome).

(@cmcsweeney)

2 anni, 7 mesi fa

Ciao @xootixsupport,

Ho scritto alcuni mesi fa e volevo controllare se “La funzione di deprezzamento WC_Cart :: get_item_data dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data. “la domanda è stata mai risolta?

(@champdor)

2 anni, 4 mesi fa

Ce l’ho ancora. Per favore @xootixsupport, correggilo!

Champdor

(@ floyd0987)

2 anni, 3 mesi fa

Sto anche ricevendo questo fastidioso errore, per favore risolvilo!

[Mon Dec 10 21:13:44.156582 2018] [proxy_fcgi:error] [pid 30344:tid 139935570900736] [client 151.67.41.170:52068] AH01071: Errore ricevuto ‘messaggio PHP: la funzione WC_Cart :: get_item_data non è considerata dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data. Messaggio NPHP: la funzione WC_Cart :: get_item_data è deprecata dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data. Messaggio NPHP: la funzione WC_Cart :: get_item_data è deprecata dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data. Messaggio NPHP: la funzione WC_Cart :: get_item_data è deprecata dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data. Messaggio NPHP: la funzione WC_Cart :: get_item_data è deprecata dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data. Messaggio NPHP: la funzione WC_Cart :: get_item_data è deprecata dalla versione 3.3. Sostituisci wc_get_formatted_cart_item_data. N ‘

(@xootixsupport)

2 anni, 3 mesi fa

Ricarica il plugin e controlla.

(@ floyd0987)

2 anni, 3 mesi fa

Grazie!

questo è l’accordo.
Controlla la versione e chiama direttamente wc_get_formatted_cart_item_data.
Ho provato a sostituire wc_get_formatted_cart_item_data con get_item_data come
WC () -> cart-> wc_get_formatted_cart_item_data e non ha funzionato. Ovviamente!
Ok, sembra che finalmente funzioni. Francamente non ha causato alcun problema sul fronte, ma quei log degli errori sembravano male e hanno dovuto eseguire il debug del problema del richiamo del gateway di pagamento e quegli errori dovevano essere rimossi.
Forse dovresti aggiungere un aggiornamento in batch alla 1.0.3.

xoo-wsc-content.php
// Meta dati
if (version_compare (WC () -> version, ‘3.3.0’, “<")) {
$ attributi. = WC () -> carrello-> get_item_data ($ cart_item);
}
altro {
$ attributi. = wc_get_formatted_cart_item_data ($ cart_item);
}

Questa risposta è stata modificata 2 anni, 3 mesi fa da.

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *