Un utente ha chiesto informazioni su Verb Lite di Wordpress

Errore: JavaScript Bootstrap richiede almeno jQuery v1.9.1

Un utente ha chiesto 👇

Dopo aver aggiornato WordPress, trovo i seguenti errori nella console del browser:

Errore non recuperato: JavaScript Bootstrap richiede jQuery v1.9.1 almeno ma meno di v3.0.0
ag theme.min.js? ver = 0.4.4: 3
ag theme.min.js? ver = 0.4.4: 3

Non riesco ad aprire correttamente la barra dei menu. È una questione di compatibilità tra il tema verb-lite e l’ultimo wordpress?

(@userpqr)

1 mese, 3 settimane fa

Ho risolto alcuni problemi con il plug-in Controllo integrità e risoluzione dei problemi. Posso vedere che tutto funziona bene quando cambio il tema. Sembra essere un conflitto con il tema Verb Lite. Per favore aiuto.

(@userpqr)

1 mese, 3 settimane fa

Un tema supporta ancora il tema Verb Lite?

(@ oksana40)

1 mese, 3 settimane fa

Ho lo stesso problema. L’ho risolto in questo modo:

In function.php aggiungi il tuo tema –

wp_deregister_script (‘jquery’);
wp_register_script (‘jquery’, ‘//cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js’, false, null);
wp_enqueue_script (‘jquery’);

(@userpqr)

1 mese, 3 settimane fa

Grazie @ oksana40 Ma il problema è che se Verb Lite smette di supportare il tema, non possiamo più usarlo.

Autore del tema

(@themely)

1 mese, 3 settimane fa

Ciao @userpqr e @ oksana40

Le mie scuse per la risposta tardiva.

@ oksana40 grazie per aver fornito la soluzione.

Abbiamo interrotto gli aggiornamenti a Verb Lite e poiché l’ultimo aggiornamento ha più di 2 anni, qualsiasi nuovo aggiornamento che rilasciamo deve passare attraverso il nuovo processo di approvazione del tema che richiederà mesi.

Se hai altre domande, saremo felici di aiutarti a risolvere.

(@userpqr)

1 mese, 3 settimane fa

Grazie @themely per la risposta. C’è qualche possibilità che otterremo l’aggiornamento?

Autore del tema

(@themely)

1 mese, 3 settimane fa

Ciao @userpqr

Ciò che ha fatto @ oksana40 è stata la soluzione giusta.

Un aggiornamento farebbe esattamente la stessa cosa.

(@userpqr)

1 mese, 2 settimane fa

Ciao @themely e @ oksana40

Grazie per la soluzione. Ho applicato lo stesso script.php al tema. Continuo a mantenere l’errore:

Errore non recuperato: JavaScript Bootstrap richiede jQuery v1.9.1 almeno ma meno di v3.0.0
ag theme.min.js? ver = 0.4.4: 3
ag theme.min.js? ver = 0.4.4: 3

Sto aggiungendo le seguenti righe in function.php: (alla fine del file)

wp_deregister_script (‘jquery’);
wp_register_script (‘jquery’, “//cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js”, false, null);
wp_enqueue_script (‘jquery’);

Mi manca qualcosa? Tieni presente che sto utilizzando un tema figlio.

Questa risposta è stata modificata 1 mese, due settimane fa da.

(@userpqr)

1 mese, 2 settimane fa

Ho implementato il seguente scripts.php:

funzione funzione () {
if (! is_admin ()) {
wp_deregister_script (‘jquery’);
wp_register_script (‘jquery’, ‘https://cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js ‘;, false, false, true);
wp_enqueue_script (‘jquery’);
}
}
add_action (‘wp_enqueue_scripts’, ‘myfunction’);

Funziona. Ma a volte ricevo il seguente errore:

TypeError Error: s.event.addProp non è una funzione
jQuery 3
aggiustare
inviato
maniglia

E, a volte dice, jquery non è definito. Per favore aiuto.

Questa risposta è stata modificata 1 mese, due settimane fa da. Questa risposta è stata modificata 1 mese, due settimane fa da. Autore del tema

(@themely)

1 mese, 2 settimane fa

Ciao @userpqr

Puoi condividere il link al sito in modo da poterlo visualizzare?

(@userpqr)

1 mese, 2 settimane fa

Ciao @themely Grazie per la risposta.

Ho cambiato wp_register_script (‘jquery’, ‘https://cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js’, false, false, true) in wp_register_script (‘jquery’, ” https://cdnjs.cloudflare.com/ajax/libs/jquery/2.2.4/jquery.min.js ‘, false, null) e ora funziona.

Autore del tema

(@themely)

1 mese, 2 settimane fa

@userpqr fantastico, contento che funzioni ora.

(@ raulperez0481)

2 settimane, 3 giorni fa

Ho aggiunto questo codice a functions.php e funziona perfettamente. La stessa cosa è successa a me in qualche altro tema e ha funzionato anche.

add_action('wp_enqueue_scripts', 'mitheme_enqueue_scripts'); 
function mitheme_lite_enqueue_scripts() { wp_deregister_script('jquery'); wp_register_script('jquery', ("https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"), false, null); wp_enqueue_script('jquery'); }

(@ negru13)

1 settimana, 3 giorni fa

Ottimo lavoro Raul, grazie!

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *