Un utente ha chiesto informazioni su Simple Calendar - Google Calendar Plugin di Wordpress

Errore critico del sito dopo l’aggiornamento

Un utente ha chiesto 👇

A seguito di un aggiornamento alla versione 3.1.32, il sito Web restituisce un errore critico per questo plug-in. Al momento ho disabilitato il plugin.

Got error 'PHP message: PHP Parse error:  syntax error, unexpected '|', expecting variable (T_VARIABLE) in /home/xxxx/apps/default/wp-content/plugins/google-calendar-events/vendor/nesbot/carbon/src/Carbon/Traits/Date.php on line 1032n', referer: https://xxxx.be/wp-admin/

Got error 'PHP message: PHP Parse error:  syntax error, unexpected '|', expecting variable (T_VARIABLE) in /home/xxxx/apps/default/wp-content/plugins/google-calendar-events/vendor/nesbot/carbon/src/Carbon/Traits/Date.php on line 1032n', referer: https://xxxx.be/wp-admin/

Got error 'PHP message: PHP Parse error:  syntax error, unexpected '|', expecting variable (T_VARIABLE) in /home/xxxx/apps/default/wp-content/plugins/google-calendar-events/vendor/nesbot/carbon/src/Carbon/Traits/Date.php on line 1032n', referer: http://xxxx.be

Got error 'PHP message: PHP Parse error:  syntax error, unexpected '|', expecting variable (T_VARIABLE) in /home/xxxx/apps/default/wp-content/plugins/google-calendar-events/vendor/nesbot/carbon/src/Carbon/Traits/Date.php on line 1032n', referer: https://xxxx.be/wp-admin/network/site-info.php?id=6

(@caionog)

4 mesi, 3 settimane fa

Ho già aggiornato php 7.4, ho provato a reinstallare il serbatoio del plugin FTP ma non è riuscito …

In attesa di soluzione …
Grazie!

(@pbwpwork)

4 mesi, 3 settimane fa

Come altri hanno già detto, non so perché questo sia contrassegnato come una soluzione quando in realtà non lo è … Ho risolto il problema riportando il plugin da 31.1.32 a 31.1.31. Come quando ho eseguito .32 con PHP 7.3.18 (WordPress 5.5.1), ha colpito l’intero sito. Tuttavia, mi piacerebbe eseguire la versione più recente poiché non so se sto aprendo eventuali falle di sicurezza sul mio sito Web utilizzando una versione precedente.

@simplecalendarsupport c’è un problema da risolvere con un aggiornamento futuro?

(@kzeni)

4 mesi, 3 settimane fa

@caionog È sempre utile fornire i dati WP_DEBUG per l’errore quando si verifica qualcosa di simile. In questo caso, c’erano una serie di errori diversi commessi da persone diverse, quindi potresti essere tu stesso un caso unico che non dovrebbe essere dimenticato, e se fornisci proattivamente quei dati allo sviluppatore può sicuramente aiutare con il problema. Risolto per te prima piuttosto che poi.

(@mgc)

4 mesi, 3 settimane fa

Ancora nessun aggiornamento ufficiale sulla correzione?

(@simplecalendarsupport)

4 mesi, 1 settimana fa

Ciao a tutti,

Oggi abbiamo eliminato la 3.1.33. Dovrebbe affrontare molti dei problemi in corso. Il plugin era molto popolare e per alcuni utenti causava problemi di installazione. Abbiamo tagliato molto. Dovrai anche assicurarti di eseguire anche PHP 7.3+ ora.

Grazie per la tua pazienza mentre lavoriamo!

(@mgc)

4 mesi, 1 settimana fa

Ci vuole ancora molto tempo per aggiornare questa versione ma funziona. Grazie, @simplecalendarsupport!

(@simplecalendarsupport)

4 mesi, 1 settimana fa

Grazie per la conferma @mgc

Dovrebbe essere meglio andare avanti poiché abbiamo ridotto i file del plugin di MOLTO. Quindi il ritardo questa volta è stato probabilmente dovuto al fatto che ha dovuto cancellare alcuni dei vecchi file.

Buon divertimento!

(@dljordaneku)

4 mesi, 1 settimana fa

Quindi tutto quello che devi fare è verificare se stai eseguendo php 5.x non funzionerà ancora.

Darrell

(@simplecalendarsupport)

4 mesi, 1 settimana fa

Giusto. Abbiamo aggiornato molti pacchetti dei fornitori per aiutare ad aggiornare le cose. Quindi ora avrai bisogno almeno di PHP 7.3 per eseguire il plugin.

(@ignaciojesus)

4 mesi fa

@simplecalendarsupport

Si prega di consultare il GuzzleHttp relativo a un problema che hai aggiornato sul plugin.

È in contraddizione con altri plugin di altri fornitori di cui abbiamo bisogno.

Ti assisto nel tentativo di risolvere questo problema se lo desideri / lo desideri.

Cordiali saluti

Inaki

(@danielrufde)

4 mesi fa

Vedi https://wordpress.org/support/topic/update-to-3-1-33-broke-my-site/page/2/#post-13515406 per le cartelle senza scrupoli dipendenze / fornitori.

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *