Un utente ha chiesto informazioni su Product Feed PRO for WooCommerce di Wordpress

Errore di analisi durante la generazione del feed

Un utente ha chiesto 👇

Ricevo questo errore mentre provo a generare il feed alla fine:

Errore di analisi: errore di sintassi, “0” (T_LNUMBER) imprevisto, variabile in attesa (T_VARIABLE) o “{” o “$” in / srv / users / serverpilot / apps / ********** *** /public/wp-content/plugins/woo-product-feed-pro/classes/class-get-products.php(460): estim () ‘d codice online 1

Grazie

Donatore di plugin

(@evavangelooven)

2 anni, 4 mesi fa

Ciao soulipsyz,

Grazie per aver utilizzato il nostro plugin e per averci contattato. Mi dispiace sentire che hai problemi con esso.

Abbiamo appena rilasciato una nuova versione del plugin (versione 3.7.6) che dovrebbe risolvere il problema.

Potresti provarlo e farci sapere se ha funzionato per te?

Ti auguro il meglio,
Eva

(@ anonimo-15183895)

2 anni, 4 mesi fa

Salve Team di supporto,

Ho un errore di analisi simile se provo a generare un feed prodotto.

Parse error: syntax error, unexpected ',' in /***/***/***/***/wp-content/plugins/woo-product-feed-pro/classes/class-get-products.php(465) : eval()'d code on line 1

Ti sarei molto grato per il tuo aiuto. La versione 3.7.7 è.

Grazie

Donatore di plugin

(@evavangelooven)

2 anni, 4 mesi fa

Ciao ansampf86,

Grazie per aver utilizzato il nostro plugin e per averci contattato. Mi dispiace sentire che hai problemi con esso.

Il problema sembra essere correlato alla configurazione dei costi di spedizione in cui una virgola è da qualche parte inaspettata. Saresti così gentile da fare alcuni screenshot delle tue impostazioni di avvio, in particolare queste due schermate:

https://www.dropbox.com/s/w5nxy8ybuxwpi4r/Shipping2.png?dl=0
https://www.dropbox.com/s/72ou74svemym8dc/Shipping1.png?dl=0

Grazie!
Eva

(@ anonimo-15183895)

2 anni, 4 mesi fa

Grazie per la tua rapida risposta, Eva.

Il tuo suggerimento ha funzionato finora. Ho cambiato le dimensioni di invio da 5.90 a 5.90 (senza virgola). Il feed è stato creato ma sfortunatamente ha generato un nuovo errore di analisi con il formato XML. Con CSV tutto funziona bene. Grazie fino ad ora 🙂

Donatore di plugin

(@evavangelooven)

2 anni, 4 mesi fa

Ciao,

È bello sapere che sei riuscito a farlo funzionare per il formato CSV. Tuttavia vogliamo ancora capire cosa sta andando storto (con il formato XML). Saresti in grado di fornire i nuovi screenshot e l’errore di analisi che ricevi?

Grazie!
Eva

(@ anonimo-15183895)

2 anni, 4 mesi fa

Ciao Eva,

ovviamente. Ecco il link alla foto.
https://www.dropbox.com/s/3gv0jju7g3jpxof/Error.png?dl=0

il migliore

Donatore di plugin

(@evavangelooven)

2 anni, 4 mesi fa

Grazie per aver inviato l’avviso PHP. Ci assicureremo che sia andato nel prossimo numero. L’avviso, tuttavia, potrebbe non essere il motivo per cui il feed XML non è riuscito.

Ti capiterà anche di avere gli screenshot per le tue impostazioni di navigazione?

Ti auguro il meglio,
Eva

(@ anonimo-15183895)

2 anni, 4 mesi fa

Hai ragione, è successo solo una volta. Sembra che funzioni ora, anche con i file XML. Perfetto.

il migliore

Donatore di plugin

(@evavangelooven)

2 anni, 4 mesi fa

È interessante notare che il problema in questione è ben risolto.

Chiudo ora la questione per ragioni interne. Non esitare a ricontattarti quando hai bisogno di aiuto.

Buon fine settimana,
Eva

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *