Un utente ha chiesto informazioni su Printful Integration for WooCommerce di Wordpress

500 Errore interno del server durante il tentativo di connessione all’archivio

Un utente ha chiesto 👇

Sto ottenendo 500 Errore interno del server messaggio nella dashboard di Printful quando desideri connettere il negozio a WooCommerce.

L’ho testato bene e il problema diventa evidente quando WooCommerce viene aggiornato alla v4.0.1. Avevo 3.8.1 per configurare il sito web e il collegamento funziona perfettamente. Stai per rilasciare una nuova versione del plugin per affrontare la compatibilità con WooCommerce?

(@snigisnago)

10 mesi fa

Ho lo stesso problema.

(@everybear)

10 mesi fa

Hey Ann,

Grazie per il contatto!
Siamo spiacenti di apprendere che hai riscontrato un problema del genere.
Potresti condividere i tuoi log degli errori con noi, così possiamo controllare cosa è successo?

Puoi inviarli qui o a feedback@printful.com!

Lanciatore di thread

(@mikacns)

10 mesi fa

PHP Fatal error: Uncaught Error: Call to a member function is_on_sale() on null in /nas/content/live/ninaaatv/wp-content/plugins/woocommerce/templates/single-product/sale-flash.php:25nStack trace:n#0 /nas/content/live/ninaaatv/wp-content/plugins/woocommerce/includes/wc-core-functions.php(251): include()n#1 /nas/content/live/ninaaatv/wp-content/plugins/woocommerce/includes/wc-template-functions.php(1565): wc_get_template('single-product/...')n#2 /nas/content/live/ninaaatv/wp-includes/class-wp-hook.php(287): woocommerce_show_product_sale_flash('')n#3 /nas/content/live/ninaaatv/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters('', Array)n#4 /nas/content/live/ninaaatv/wp-includes/plugin.php(478): WP_Hook->do_action(Array)n#5 /nas/content/live/ninaaatv/wp-content/plugins/woocommerce/templates/content-single-product.php(43): do_action('woocommerce_bef...')n#6 /nas/content/live/ninaaatv/wp-includes/template.php(725): require('/nas/content/li...')n#7 /nas/content/live/ninaaatv/wp-content/plugins/woocommerce/includes/wc-core-functions in /nas/content/live/ninaaatv/wp-content/plugins/woocommerce/templates/single-product/sale-flash.php on line 25

Questa risposta è stata modificata 10 mesi fa da. Questa risposta è stata modificata 10 mesi fa da.

(@everybear)

9 mesi, 3 settimane fa

Hey Ann,

Grazie per aver condiviso con noi i tuoi log degli errori!
Questo è stato verificato dal nostro team di sviluppatori e sembra essere un errore interno del server causato da qualcosa che blocca la connessione dalla tua parte. Non possiamo vedere alcun dato aggiuntivo poiché l’errore si verifica sul lato hosting del server. Ciò potrebbe essere causato da un conflitto tra plug-in, tema, impostazioni del firewall, impostazioni del server, ecc.

Tuttavia, puoi contattare il tuo provider di hosting per ulteriori dettagli sulla risoluzione di questo problema!

Lanciatore di thread

(@mikacns)

9 mesi, 3 settimane fa

Ho già provato a risolvere questo problema con il mio host (WPengine) ma dicono che tutto va bene dal loro lato.

Ho attivato tutti i plugin tranne WooCommerce e sono passato a un tema WP predefinito. Con queste condizioni l’errore è visibile SOLO quando si utilizza la versione più recente di WooCommerce. Come ho detto prima, funziona perfettamente v3.8.1. Puoi confermare che funziona correttamente con l’ultima versione di WooCommerce?

(@everybear)

9 mesi, 3 settimane fa

Hey Ann,

Grazie per essere tornato da noi!
Il nostro plugin è compatibile con l’ultima versione di WooCommerce.
L’errore interno del server 500 è un codice di stato HTTP molto generale, il che significa che qualcosa non va con il server del sito Web, ma il server non potrebbe essere più specifico su quale sia il problema esatto.
Abbiamo ricontrollato i tuoi log degli errori per assicurarci che si tratti di un errore interno del server 500, ma non possiamo davvero aiutarti a risolverli, poiché l’errore si verifica sul lato server del server.

Se il tuo host può condividere maggiori dettagli su questo e se crede che abbia qualcosa a che fare con il nostro plugin, lo apprezzeremmo sicuramente!

(@mezpow)

4 mesi, 4 settimane fa

Ciao, ora ricevo questo errore. Questo problema è stato risolto sul tuo sito web?

Lanciatore di thread

(@mikacns)

4 mesi, 4 settimane fa

C’era un pezzo di codice personalizzato che doveva essere modificato in functions.php e successivamente ha funzionato. Consiglio di provare a risolvere i problemi disattivando i plug-in uno per uno e quindi provandolo o passando a un tema WordPress predefinito.

(@mezpow)

4 mesi, 4 settimane fa

grazie proverò:

Ricevo quanto segue nel mio registro degli errori, quindi mi chiedo se questo abbia qualcosa a che fare con esso:

get_cart was called incorrectly. Get cart should not be called before the wp_loaded action. 

Backtrace: require('wp-blog-header.php'), 
require_once('wp-load.php'), 
require_once('wp-config.php'), 
require_once('wp-settings.php'), 
do_action('init'), 

WP_Hook-> do_action, 
WP_Hook->apply_filters, vcvinit, 

VisualComposerApplication->init, vcevent, 
VisualComposerFrameworkIlluminateEventsDispatcher->fire, 
VisualComposerFrameworkIlluminateContainerContainer->call, call_user_func_array, 
VisualComposerModulesSystemAjaxController->VisualComposerHelpersTraits{closure}, 
VisualComposerFrameworkContainer->call, ReflectionMethod->invokeArgs, 
VisualComposerModulesSystemAjaxController->listenAjax, 
VisualComposerFrameworkContainer->call, ReflectionMethod->invokeArgs, 
VisualComposerModulesSystemAjaxController->parseRequest, 
VisualComposerFrameworkContainer->call, ReflectionMethod->invokeArgs, 
VisualComposerModulesSystemAjaxController->getResponse, 
vcfilter, VisualComposerFrameworkIlluminateFiltersDispatcher->fire, 
VisualComposerFrameworkIlluminateContainerContainer->call, call_user_func_array, 
VisualComposerModulesElementsAjaxShortcodeController->VisualComposerHelpersTraits{closure}, 
VisualComposerFrameworkContainer->call, ReflectionMethod->invokeArgs, 
VisualComposerModulesElementsAjaxShortcodeController->render, wp_footer, do_action('wp_footer'), 

WP_Hook->do_action, 
WP_Hook->apply_filters, 

Xoo_Wsc_Frontend->cart_markup, 
Xoo_Helper->get_template, 
include('/plugins/side-cart-woocommerce/templates/xoo-wsc-markup.php'), Xoo_Helper->get_template, 
include('/plugins/side-cart-woocommerce/templates/xoo-wsc-container.php'), Xoo_Helper->get_template, 
include('/plugins/side-cart-woocommerce/templates/xoo-wsc-header.php'), Xoo_Wsc_Cart->print_notices_html, 
do_action('woocommerce_check_cart_items'), 

WP_Hook->do_action, 

WP_Hook->apply_filters, 
WC_Cart->check_cart_items, 
WC_Cart->check_cart_item_validity, 
WC_Cart->get_cart, wc_doing_it_wrong. 

This message was added in version 2.3.

In realtà ho installato SideCart dopo l’errore, quindi per ora sto controllando il problema.

Questa risposta è stata modificata 4 mesi, 4 settimane fa da.

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *