Un utente ha chiesto informazioni su Email marketing and Subscribe forms by Sendinblue

  • Newsletter
  • SMTP di Wordpress

    Errore del database con Inquiry Monitor “DESCRIBE IF;”

  • Un utente ha chiesto 👇

    Durante l’utilizzo della versione più recente 2.9.3 ottengo due volte il seguente errore su Query Monitor:

    Errori del database
    1) Domanda
    2) Caller
    3) Componente
    4) Messaggio di errore
    5) Codice di errore

    1) DESCRIVERE SE;
    2) Sconosciuto
    3) Sconosciuto
    4) Hai un errore nella sintassi SQL; controllare il manuale corrispondente alla versione del server MySQL per utilizzare la sintassi corretta accanto a “IF” alla riga 1
    5) qmdb

    Quando torno alla versione precedente non ci sono errori.

    (@ituk)

    2 anni, 3 mesi fa

    Ho fatto lo stesso errore: https://screenshots.firefox.com/rlrJH4pB0iG8mXJq/www.bayadaim.org.il

    Lanciatore di thread

    (@opicron)

    2 anni, 3 mesi fa

    Alla fine ho rimosso le chiamate dell’app della tabella f dal plug-in. Il caso è stato risolto.

    Ho controllato la vecchia versione e ci sono differenze tra questa versione e quelle particolari funzioni. Non ce n’è, ma invece di disinfettarlo da solo lo lascio al diavolo.

    (@ituk)

    2 anni, 3 mesi fa

    quale file?

    (@morvy)

    2 anni, 1 mese fa

    ancora irrisolto 🙁

    commentare le righe 186 e 188 nel file sendinblue.php.

    // crea tabelle modulo e crea un modulo predefinito.
    / * SIB_Forms :: createTable (); * /
    // crea una tabella utente.
    / * SIB_Model_Users :: createTable (); * /

    (@johnmcole)

    2 anni fa

    Lo vedo anche io. Immagino che stiamo aspettando un aggiornamento e una correzione da SendinBlue?

    Lanciatore di thread

    (@opicron)

    2 anni fa

    SendInBlue incolpa Inquiry Monitor. Che in linea di principio potrebbe essere corretto perché sql non è cambiato tra questa e la vecchia versione. È piuttosto strano ..

    Autore del plugin

    (@neeraj_slit)

    2 anni fa

    Ciao,

    Grazie per aver segnalato l’errore.
    Il nostro team sta valutando la nostra prossima versione!

    Di,

    (@fulviods)

    1 anno, 11 mesi fa

    Ciao

    Ho anche questo errore. Questo errore è lo stesso?
    Puoi vedere un’immagine qui: https://ibb.co/g3c908H

    Poiché l’ultimo messaggio è di 1 mese fa, mi chiedo se questo aggiornamento di stile è in arrivo?
    Grazie

    Lanciatore di thread

    (@opicron)

    1 anno, 11 mesi fa

    L’aggiornamento deve ancora arrivare. 🙁

    (@solargard)

    1 anno, 11 mesi fa

    Ho trovato che funziona usando $ wpdb-> query ($ create_query) invece di dbDelta ($ create_query) nei file seguenti:

    /plugins/mailin/model/model-forms.php:56
    /plugins/mailin/model/model-users.php:44
    /plugins/mailin/model/model-lang.php:32

    Sembra esserci un problema con la sintassi dell’istruzione SQL per “CREATE TABLE IF NOT EXISTS” poiché la funzione dbDelta () mostrerà “IF” come nome della tabella che butta via tutto.

    Spero che questo aiuti qualcuno!

    (@morvy)

    1 anno, 11 mesi fa

    Grazie solargard, questo mi ha aiutato anche con altri plugin. DbDelta non sembra essere molto utile o utilizzato in modo improprio.

    Tuttavia, avevamo un aggiornamento per il plug-in e questo bug non è stato risolto, quindi ho dovuto correggerlo di nuovo da solo.

    (@ituk)

    1 anno, 10 mesi fa

    La domanda @neeraj_slit si applica ancora dopo l’aggiornamento del plug-in: cosa facciamo?

    Lanciatore di thread

    (@opicron)

    1 anno, 10 mesi fa

    Mi asterrò dall’aggiornamento finché questo ID non vi aderirà.

    (@convers)

    1 anno, 10 mesi fa

    Ho installato ieri questo plugin (versione: 2.9.4) e ho ricevuto anche questo errore grazie a Query Monitor; Ho esaminato le mie tabelle MariaDB e tutto era ok nonostante la notifica di errore.

    A causa di una notifica di errore ogni volta che le pagine vengono caricate (e si verifica un piccolo attacco di panico), ho utilizzato una soluzione fornita da @solargard dopo + l’indagine sull’installazione.
    $wpdb->query($creation_query); // dbDelta( $creation_query );

    Controllando di nuovo la mia SS, è tutto a posto, oltre a non più notifiche di errore rosse ora.
    (Non ho eliminato le tabelle per verificare se questa soluzione funziona da sola – segnala i tentativi.)

    Mi chiedo perché questo errore viene attivato su tutti i caricamenti di pagina? .. sicuro createTable() le funzioni sono richieste solo durante l’attivazione dell’installazione iniziale e negli aggiornamenti del plugin? (Non ho tempo per indagare su questo, per favore segnala / aggiorna se necessario.)

    Questa risposta è stata modificata 1 anno, 10 mesi fa.

    (@morvy)

    1 anno, 8 mesi fa

    2.9.5 è uscito e il problema non è stato ancora risolto. Ancora una volta, è necessario modificare un plug-in per risolvere il problema. Non è possibile applicare l’impostazione nel plug-in? Hai la soluzione qui, quindi perché viene di nuovo nel plugin?

    Was this helpful?

    0 / 0

    Lascia un commento 0

    Your email address will not be published. Required fields are marked *