Un utente ha chiesto informazioni su Mammoth .docx converter di Wordpress

Errore di conversione di Docx

Un utente ha chiesto 👇

Errore durante il tentativo di conversione del file: impossibile leggere gli “attributi” della proprietà non specificata

L’errore sopra è stato attivato dopo aver aggiornato woocommerce 4.3.0.

In precedenza ho provato a inserire file che potevano essere caricati con successo e ora tutti i file docx attivano questo errore.

(@winecurmudgeon)

6 mesi, 1 settimana fa

Ho ricevuto lo stesso messaggio di errore – Errore durante il tentativo di conversione del file: impossibile leggere gli “attributi” della proprietà non specificata

Ho disattivato la mia versione aggiornata di woocommerce, 4.31, ma ho ricevuto lo stesso messaggio di errore.

Potrebbe essere così semplice? “Attenzione: questo plugin non è stato testato con la tua attuale versione di WordPress.” Sono il 5.4.2

Questa risposta è stata modificata 6 mesi, una settimana fa da.

(@seyemore)

6 mesi, 1 settimana fa

Ho la stessa domanda e non ho woocommerce. Spero che lo sviluppatore risolva il problema poiché consiglio sempre questo plug-in ai miei clienti.

C’è un altro plugin alternativo se questo non è stato risolto?

——————————-
Messaggio di errore su tutti i file .doxc caricati in precedenza:

Errore durante il tentativo di conversione del file: impossibile leggere gli “attributi” della proprietà non specificata

Autore del plugin

(@michaelwilliamson)

6 mesi, 1 settimana fa

Ho appena provato Mammoth su WordPress 5.4.2 con WooCommerce installato e il plugin ha funzionato perfettamente per me.

Potresti provare il plugin senza altri plugin con il tema predefinito installato e vedere se hai lo stesso problema?

Inoltre, potresti fornire un documento di esempio?

Lanciatore di thread

(@wuxu)

6 mesi, 1 settimana fa

Michael Williamson, un chara,
Grazie per il vostro supporto, in wordpress arriva una nuova funzionalità per l’articolo. Quando installi woocommerce, sullo sfondo del sito è presente una pagina aggiuntiva del prodotto.
1, quindi quando carichi il file docx utilizzando il tuo plugin nella pagina dell’articolo, verrà pubblicato nella sezione directory degli articoli del blog, se utilizzi il prodotto per aggiungere una pagina e utilizzi il tuo plugin al file docx caricato, sarà pubblicato nella directory degli articoli in forma di prodotto.
2, ora aggiornato sul woocommerce, utilizzo la tua pagina articolo non comporterà errori nella pagina dell’articolo.
3. Gli errori si verificano solo nella pagina del prodotto di woocommerce.
4, quindi prima di aggiornare il plugin, risolverò il problema come segue. Per prima cosa passa docx nella pagina dell’articolo, quindi copia tutto il testo del codice sorgente (devi attivare l’editor classico) nella pagina di caricamento del prodotto.

Dal quarto punto, non credo che woocommerce sia compatibile con il tuo plugin. Perché il tuo plugin funziona nell’editor di testo originale di wordpress.

——————————————————
Lo trovo anche nella console degli sviluppatori: come accennato in precedenza, gli errori si verificano solo nella pagina di modifica del nuovo prodotto.

mammut-editor.js? v = 1.15.0: 194 TypeError: Impossibile leggere gli “attributi” di proprietà non specificati
di Module.Ue (bloic.min.js: 3)
di insertTextIntoEditor (mammoth-editor.js? v = 1.15.0: 177)
di mammoth-editor.js? v = 1.15.0: 92
di tryCatcher (mammoth-editor.js? v = 1.15.0: 5641)
su Promise._settlePromiseFromHandler (mammoth-editor.js? v = 1.15.0: 3660)
su Promise._settlePromise (mammoth-editor.js? v = 1.15.0: 3717)
su Promise._settlePromise0 (mammoth-editor.js? v = 1.15.0: 3762)
su Promise._settlePromises (mammoth-editor.js? v = 1.15.0: 3841)
di Async._drainQueue (mammoth-editor.js? v = 1.15.0: 616)
di Async._drainQueues (mammoth-editor.js? v = 1.15.0: 626)
di Async.drainQueues (mammoth-editor.js? v = 1.15.0: 500)

(@winecurmudgeon)

6 mesi, 1 settimana fa

Ciao Michael.

Quando carico il file docx nel convertitore, il post viene visualizzato correttamente nel visualizzatore di Mammoth, i collegamenti e tutto il resto. Posso tagliarlo e incollarlo nell’editor dei post. Sto usando l’ultima versione del classico plugin dell’editor. Anche l’HTML grezzo sembra a posto.

Tuttavia, quando guardo i messaggi, ottengo questi: “Avviso: stile corrente sconosciuto:” Connessione Internet “(ID stile: InternetLink)

Quindi, quando premo il pulsante Invio, ottengo lo stesso errore di tutti gli altri.

Spero che questo aiuti. Per favore fatemi sapere se posso inviarvi qualcos’altro.

(@rogeliohm)

6 mesi, 1 settimana fa

Ciao.
Non utilizzo Wocommerce sul mio sito, ma utilizzo il plugin Yoast SEO, dopo l’aggiornamento alla versione 14.7 Yoast SEO ho riscontrato l’errore nel convertitore .docx di Mammoth. Quando ho provato a caricare un file .docx l’errore è stato: “Errore durante il tentativo di conversione del file: Impossibile leggere la proprietà non specificata” attributi “”. Ma se disattivo il plugin Yoast SEO, il convertitore Mammoth .docx funziona senza problemi.
Di

(@winecurmudgeon)

6 mesi, 1 settimana fa

Ho provato a far funzionare il plugin tramite Yoast e un altro plugin Yoast, disattivando i post duplicati. Ho dovuto disattivarli entrambi per far lavorare la nonna. Se solo disattivassi l’uno o l’altro, non funzionerebbe. Inoltre, anche quando ho disattivato entrambi, ho ricevuto un messaggio di errore prima del passaggio con successo: “Avviso: stile corrente sconosciuto:” Connessione Internet “(ID stile: InternetLink)

Posso inviarti alcuni screenshot; Qual’è il miglior modo di farlo?

Questa risposta è stata modificata 6 mesi, una settimana fa da. Questa risposta è stata modificata 6 mesi, una settimana fa da.

(@danemorgan)

6 mesi, 1 settimana fa

Uno dei miei clienti riceve questo errore. Nessun WooCommerce installato, ma abbiamo tracciato il conflitto su Yoast. Ritorno alla funzionalità di ripristino Yoast 14.6.1.

Autore del plugin

(@michaelwilliamson)

6 mesi fa

Grazie per le segnalazioni con Yoast. Hai altri plugin installati, come l’Editor classico, o Yoast è l’unico altro plugin?

(@winecurmudgeon)

6 mesi fa

Sì, Classic Editor è installato, insieme a molti altri, circa 20 per vari compiti: anti-spam, ordinamento dei media, ecc.

Autore del plugin

(@michaelwilliamson)

6 mesi fa

Ho pubblicato una nuova versione (1.16.0) che aggiorna il modo in cui si sente l’editor di Gutenberg. Potresti provare a vedere se hai ancora la stessa domanda?

(@winecurmudgeon)

6 mesi fa

La buona notizia è che è cambiata. La cattiva notizia è che non posso passare alla scheda di testo e non posso aggiungere collegamenti dall’editor dopo la conversione.

Non ho ricevuto alcun messaggio di errore, prima o dopo la conversione.

Ora, non lo capivo, ma sono stato aggiornato a WordPress 5.5 appena prima di provare Mammoth.

Fammi sapere se hai bisogno di qualcos’altro.

Questa risposta è stata modificata 6 mesi fa da. Autore del plugin

(@michaelwilliamson)

6 mesi fa

Temo di non avere lo stesso problema quando ho provato WordPress 5.5. Hai trovato errori nella console Strumenti per sviluppatori? Hai la stessa domanda se disabiliti tutti gli altri plugin?

(@winecurmudgeon)

6 mesi fa

Non credo che il mio problema sia enorme. Penso che sia un editor classico. Ho provato a scrivere un post nell’editor e la stessa cosa è successa: nessun accesso visivo e nessun accesso al collegamento.

Quindi sembri una nonna costante. Grazie.

(@rogeliohm)

6 mesi fa

Grazie @michaelwilliamson
Risolto il problema con il nuovo aggiornamento del convertitore .docx di Mammoth.
Io ho:
Wordpress versione 5.5
Yoast SEO versione 14.7.0
Editor classico versione 1.6
Mammoth Converter .docx Versione 1.16.0

Tutto funziona perfettamente. Grazie ancora e saluti.

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *