Un utente ha chiesto informazioni su Fixing WordPress di Wordpress

spago (0)

Un utente ha chiesto 👇

Ciao,

Per un po ‘l’ho fatto string(0) lo mostra brevemente di tanto in tanto.

Anche su alcuni aggiornamenti di plugin ottengo qualcosa di simile
Update Failed: string(0) "" string(0) "" {"success":true,"data":{"update":"plugin","slug":"the plugin name","oldVersion":"Version 6.73","newVersion":"Version 7.23","plugin":"The plugin name/ThePluginName.php","pluginName":"The plugin name"}}

In effetti, l’aggiornamento riesce come indicato in "success":true,"data":....

Ma mi chiedo perché questo filo (0) esista, mi preoccupa.

Debian 9
PHP 7.0.33
WP 4.9.8

Hai qualche idea?

Grazie
Patrice

(@patricevigier)

8 mesi fa

Lo capisco anch’io

string(0) "" string(0) "" Notice:  unserialize(): Error at offset 0 of 134696 bytes in 
/xxx/xxx/xxx/wp-content/themes/xxxxr/am/classes/class-wc-plugin-update.php

(@Gioiosamente)

8 mesi fa

Il tuo tema sembra avere un meccanismo di aggiornamento interno, che ha un problema.
Dato che ciò non è consentito nei temi che si trovano nel repository e che supportiamo solo i temi nel repository, è necessario chiederli al forum di supporto dei temi.

Inoltre, almeno aggiorna il tuo sito a WP 4.9.15, uscito oggi. Anche il tuo PHP è un po ‘vecchio, ma se aggiorni il tuo PHP, vedrai più annunci perché WP 4.9 non ha gli ultimi aggiornamenti PHP.

Inoltre, se si tratta di un sito di produzione, perché avere WP_DEBUG? Non dovresti vedere nessuno di quei messaggi. https://wordpress.org/support/article/editing-wp-config-php/#wp_debug

(@patricevigier)

8 mesi fa

Ciao gioia,
Grazie mille per la tua risposta.
Su tuo suggerimento ho aggiornato alla 4.9.15
Sto usando Debian stabile e la loro ultima versione è PHP 7.0.33. Per la stabilità è meglio aspettare la sua versione stabile perché è molto stabile!
Ho il debugger perché non lo sto ancora producendo.
Non sono sicuro che il tema sia il problema perché questo accade solo in amministrazione ma li contatterò.
Stai attento
Patrice

(@Gioiosamente)

8 mesi fa

Se non è il tema (almeno parte di esso), puoi considerare di passare al classico, che ha le ultime impostazioni PHP ma è fondamentalmente WP 4.9.

(@Gioiosamente)

8 mesi fa

Nel team di supporto di oggi, ho chiesto un elenco di versioni WP e PHP. Mi hanno mostrato questa pagina, che non avevo mai visto prima: https://make.wordpress.org/core/handbook/references/php-compatibility-and-wordpress-versions/

(@patricevigier)

8 mesi fa

Ciao gioia,

Ottimo collegamento per la compatibilità PHP.

Ho seguito i tuoi consigli e aggiornato il mio tema, per quanto mi carica, il messaggio è andato via. Quindi questo è probabilmente il problema.

Grazie ancora.
Patrice

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *