Un utente ha chiesto informazioni su Fixing WordPress di Wordpress

Aggiornamento WordPress 3.2.1.

Un utente ha chiesto 👇

Cari tutti, cari
All’inizio sono nuovo qui e cerco risposte su Google / Forum ma non ho trovato + spero di essere nel posto giusto.
Voglio aggiornare il vecchio sito web del mio amico. Ha WordPress 3.2.1.
Ma quando desidero eseguire l’aggiornamento a WordPress 5.2.2, viene visualizzato il messaggio “Non è possibile eseguire l’aggiornamento perché WordPress 5.2.2 richiede la versione PHP 5.6.20 o successiva. Stai eseguendo la versione 5.4.16. “
Ho provato a contattare il loro server (digitalocean) ma non lo supportano, quindi ho parlato con Domain (Papaki.gr) e ho comprato solo un nuovo SSL per il sito web.
1. C’è un altro modo per eseguire l’aggiornamento?
2. Utilizza il tema 1439 e vogliamo cambiare il colore di sfondo (da nero a bianco) ma non è riuscito (prova il plugin “SiteOrigin CSS” e qualche altro o prova CSS personalizzato, forse è rilevante per l’aggiornamento ??
Grazie in anticipo!
Kruvi

(@felipeloureirosantos)

1 anno, 9 mesi fa

Ciao,

Non è una risposta semplice qui.

1. C’è un altro modo per eseguire l’aggiornamento?

Ho appena dato un’occhiata al tuo sito web. Vedo che sta usando il flash che è una vecchia tecnologia.

Il mio consiglio qui è di avviare un nuovo sito web da zero. È possibile creare un nuovo sito Web copiando e incollando il contenuto. Qui puoi vedere alcuni fantastici temi: https://wordpress.org/themes/browse/featured/

2. Utilizza il tema 1439 e vogliamo cambiare il colore di sfondo (da nero a bianco) ma non è riuscito (prova il plugin “SiteOrigin CSS” e qualche altro o prova CSS personalizzato, forse è rilevante per l’aggiornamento ??

Puoi provare questo CSS (cambia il “blu” nel colore che desideri):

main {
    background-color: blue !important;
}

Ma elogio quello che ho detto sopra.

(@sterndata)

Moderatore del forum e volontario del team di supporto

1 anno, 9 mesi fa

Richiede >> 5.2.2 PHP versione 5.6.20 o successiva. Stai eseguendo la versione 5.4.16. “<

Questo non ha nulla a che fare con SSL.

Digital Ocean fornisce solo server. Qualcun altro ha i diritti di amministrazione del sistema su quel server e devi aggiornare PHP a una versione più recente. Il modo in cui lo fai dipende dalla distribuzione Linux che stai utilizzando e da come l’hai installata.

Questa risposta è stata modificata 1 anno, 9 mesi fa da. Lanciatore di thread

(@kruvi)

1 anno, 9 mesi fa

Grazie Felipe Loureiro dos Santos,
Ho provato il CSS che hai scritto ma il colore “Black” non è cambiato.
Ho provato altri temi come koksijde Le erikdmitchell + Astra Le Brainstorm Force + Hestia By Themeisle = tutti mi hanno dato una pagina vuota.
Il problema è profondo, lo so. Ma qual è il motivo? Il server PHP? SSL? se eseguo l’aggiornamento a server + SSL so che potrei aggiornare WP e forse il problema verrà risolto .. ??
In caso contrario, sto cercando di evitarlo.
Grazie ancora,
Kruvi

(@felipeloureirosantos)

1 anno, 9 mesi fa

@kruvi, nel caso in cui decidessi di aggiornare effettivamente, quindi per favore procurati un backup e non perderai il tuo sito web per paura che accada qualcosa: https://wordpress.org/support/article/wordpress-backups/

(@felipeloureirosantos)

1 anno, 9 mesi fa

Decisamente. Ecco perché ho detto di andare dall’inizio. È un enorme aggiornamento. 😉

(@felipeloureirosantos)

1 anno, 9 mesi fa

Come ha detto @sterndata: non è SSL. Forse la tua versione PHP, versione tema / plugin o conflitto tema / plugin.

Lanciatore di thread

(@kruvi)

1 anno, 9 mesi fa

Felipe Loureiro dos Santos – L’ho già fatto 😉 grazie.

Steve Stern – Ok ora ha senso, ma non ho capito “dipende dalla distribuzione Linux che stai utilizzando e da come l’hai installata.” – Hai intenzione di accedere / accedere a digitalocean e provarlo? Per rimuovere quella ??

Penso che la soluzione migliore e più semplice sia cambiare il server con un sito sicuro SSL, ho ricevuto un’offerta dal nostro dominio e loro faranno tutto il lavoro e tutti i dati verranno salvati.

Grazie ragazzi

Questa risposta è stata modificata 1 anno, 9 mesi fa da.

(@jnashhawkins)

1 anno, 9 mesi fa

Sei sicuro che il loro account Digital Ocean non abbia supporto? Non lo so, ma penso che avrebbero un ottimo supporto.

Il tuo registrar di domini, Papaki.gr, non può aiutarti con un problema di hosting su Digital Ocean.

Le altre opzioni sono spostare il sito Web su un altro host, assumere qualcuno per aggiornare la tua versione PHP, aggiornare quel PHP da solo o prendere in considerazione l’installazione dell’aggiornamento alla versione 4.9.10 di WordPress precedente dovrebbe essere buono e ancora funzionare con il tuo PHP corrente. . Questo plugin dovrebbe aiutare a controllare l’aggiornamento e il processo.

Easy Updates Manager

Mi piacerebbe comunque avere la versione aggiornata di PHP!

Ecco alcune discussioni sull’installazione di 4.9.10 incluso un po ‘di codice per interrompere l’ulteriore aggiornamento e c’è un altro plugin per aiutare a controllare ulteriormente il processo di aggiornamento, se lo desideri.

https://wordpress.org/support/topic/wordpress-4-9-10-update/

Immagino che quando tutto è stato detto e fatto, probabilmente farai solo l’aggiornamento manuale a 4.9.10.

Updating WordPress

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *