Un utente ha chiesto informazioni su Companion Auto Update di Wordpress

CAU 3.7.1 Errore irreversibile

Un utente ha chiesto 👇

Si prega di controllare,

Below are the last 7 updates ran on this site. Includes plugins and themes, both automatically updated and manually updated.

Fatal error: Uncaught Error: Call to undefined function wp_next_schedule() in /location/example.com/wp-content/plugins/companion-auto-update/cau_functions.php:787 Stack trace: #0 /location/example.com/wp-content/plugins/companion-auto-update/companion-auto-update.php(294): cau_fetch_log('7') #1 /location/example.com/wp-admin/includes/template.php(1389): cau_widget('', Array) #2 /location/example.com/wp-admin/includes/dashboard.php(246): do_meta_boxes(Object(WP_Screen), 'normal', '') #3 /location/example.com/wp-admin/index.php(177): wp_dashboard() #4 {main} thrown in /location/example.com/wp-content/plugins/companion-auto-update/cau_functions.php on line 787

There has been a critical error on your website. Please check your site admin email inbox for instructions.

Ho una CAU disabilitata sul mio sito. Alla ricerca di un plugin alternativo.

(@stevengliebe)

4 mesi, 2 settimane fa

Vedo la stessa cosa su Update Log sul pannello WP.

(@sankari)

4 mesi, 2 settimane fa

Quasi lo stesso messaggio di errore qui:

Errore non riconosciuto: chiama la funzione non specificata wp_next_schedule () in /location/example.com/httpdocs/wp-content/plugins/companion-auto-update/cau_functions.php:787
Pista di impilamento:
# 0 /location/example.com/wp-content/plugins/companion-auto-update/companion-auto-update.php(294): cau_fetch_log (‘7’)
# 1 /location/example.com/wp-admin/includes/template.php(1389): cau_widget (“, Modifica)
# 2 /location/example.com/wp-admin/includes/dashboard.php(246): do_meta_boxes (Object (WP_Screen), ‘normal’, “)
# 3 /location/example.com/wp-admin/index.php(177): wp_dashboard ()
# 4 {main}
cast

Non so se sia correlato ad esso, ma la dashboard sembra rotta, cioè non tutte le caselle vengono visualizzate (l’ultima è la casella di accesso aggiornato) e gli show / skin sono disabilitati per tutte le caselle.

Versione plugin 3.7.1.
WordPress versione 5.5.3

(@sankari)

4 mesi, 2 settimane fa

Appendice:
Ho notato solo che il pannello è tornato alla normalità se il plug-in è disattivato, quindi entrambi sembrano essere correlati.

(@tisnickske)

4 mesi, 2 settimane fa

Ricevo anche lo stesso messaggio di errore con CAU v3.7.1 installato: “Il tuo sito web ha riscontrato un errore critico. Controlla la posta in arrivo del tuo sito per le istruzioni. ‘
E sì, il pannello sembra essere rotto non mostrando tutte le scatole.
Quando utilizzo il plug-in WP Rollback per installare la versione precedente (v3.7.0) di CAU, tutto torna alla normalità.

WordPress v5.5.3

(@robtcyn)

4 mesi, 2 settimane fa

Esattamente lo stesso problema – Dettagli per i neofiti: Auto Companion Update è un plugin. Di solito funziona molto bene. Con questo bug, mi ha permesso di accedere, ma dopo un errore di accesso. Se vai su una pagina e poi MODIFICA quella pagina, e poi se vai in un plugin, disabilita CAU. Per sicurezza, dopo aver disconnesso e poi di nuovo in. Il mio funziona perfettamente dopo la disattivazione. Mi piace CAU, quindi non è stato cancellato. Si spera che questo bug venga risolto il prossimo mese o giù di lì.
WordPress 5.5.3 che esegue il tema Twenty Sixteen.

(@hansendo)

4 mesi, 2 settimane fa

Potrebbe essere “wp_next_scheduled ()” invece di “wp_next_schedule ()”.

(@stevengliebe)

4 mesi, 2 settimane fa

Tutti i casi di wp_next_schedule( per wp_next_scheduled( in wp-content / plugins / companion-auto-update /cau_functions.php sembra che faccia il trucco da ora in poi. Grazie @hansendo.

(@studboo)

4 mesi, 2 settimane fa

Ho la stessa domanda sul mio sito, studboo.com 😐

Di seguito sono riportati gli ultimi sette aggiornamenti eseguiti su questo sito. Include plugin e temi, che vengono aggiornati automaticamente e aggiornati manualmente.

Si è verificato un errore critico sul tuo sito web. Controlla la posta in arrivo del tuo sito per le istruzioni.

(@narkanister)

4 mesi, 2 settimane fa

Anche a me:

Errore irreversibile PHP: errore non riconosciuto: chiama la funzione non definita wp_next_schedule () in /wp-content/plugins/companion-auto-update/cau_functions.php:317

(@luxxor)

4 mesi, 2 settimane fa

Correzioni 3.7.1:
https://gist.github.com/marcissimus/a8b0eaae48ce103ff950c5f4949b9ab4

Autore del plugin

(@papin)

4 mesi, 2 settimane fa

Oof, questo è brutto .. Come ho fatto a perdere quello? Ad ogni modo, è stato risolto nella versione 3.7.1.1 🙂

Lanciatore di thread

(@ minhazul007)

4 mesi, 2 settimane fa

@papin ha appena aggiornato CAU. Sì! È sistemato! Vi ringrazio molto! ^ _ ^ SI PREGA DI RICEVERE IL VOSTRO CODICE PER AVERE UNA PUBBLICAZIONE! Godspeed.

(@stevengliebe)

4 mesi, 2 settimane fa

Grazie @papin per questo plug-in veloce e molto pratico! Apprezziamo il tuo lavoro.

Autore del plugin

(@papin)

4 mesi, 2 settimane fa

@ minhazul007 e @stevengliebe nessun problema!

Questa è stata la prima volta che ho eseguito un aggiornamento e sarà l’ultimo, la prossima volta anche la patch più piccola verrà testata per un po ‘prima di essere pubblicata live 😅

(@sankari)

4 mesi, 2 settimane fa

@papin Grazie anche da parte mia. La vita offre molte opportunità di apprendimento e come dice il proverbio: “La pace è calma” 🙂 Continua il buon lavoro e grazie per averlo condiviso con la comunità WP.

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *