Un utente ha chiesto informazioni su Awesome Support - WordPress HelpDesk & Support Plugin di Wordpress

Campi personalizzati non visualizzati

Un utente ha chiesto 👇

Ciao,

Non so perché ma i campi personalizzati non vengono più visualizzati nel frontend. Alla fine sembra tutto a posto.

Ecco cosa ho aggiunto a /wp-content/plugins/awesome-support-custom-fields.php:

// Se questo file viene fornito direttamente, aborto.
if (! defined (‘WPINC’)) {
Morte;
}

add_action (‘plugins_loaded’, ‘wpas_user_custom_fields’);
/ **
* Registra tutti i campi personalizzati dopo che il plugin è stato caricato in modo sicuro.
* /
funzione wpas_user_custom_fields () {
/ * Puoi iniziare ad aggiungere i tuoi campi personalizzati in modo sicuro dopo questa riga * /

if (function_exists (‘wpas_add_custom_taxonomy’)) {
wpas_add_custom_taxonomy (‘errorhandler’, array (‘title’ => ‘Kategorie’, ‘label’ => ‘Auftrag’, ‘label_plural’ => ‘Kategorie’, ‘order’ => ‘3’));
}
if (function_exists (‘wpas_add_custom_field’)) {
wpas_add_custom_field (‘website’, edit (‘title’ => ‘Domain’, ‘label’ => ‘Website-URL *’, ‘label_plural’ => ‘Website’, ‘field_type’ => ‘url’, ‘placeholder’ => ‘https: // & # 8217;, ‘order’ => ‘1’, ‘required’ => true));
}
if (function_exists (‘wpas_add_custom_field’)) {
wpas_add_custom_field (‘ip_adress’, edit (‘title’ => ‘IP-Adresse’, ‘label’ => ‘IP-Adresse’, ‘label_plural’ => ‘IP-Adresse’, ‘field_type’ => ‘text’, ‘placeholder’ => ‘www.wieistmeineip.at’, ‘order’ => ‘2’));
}

/ * NON scrivere nulla dopo questa riga * /
}

Impossibile trovare errori 🙁

mi aiuti per favore

(@zanyojimbo)

2 anni, 10 mesi fa

Ciao, ho la stessa domanda, come accennato in un altro post – anche un semplice esempio AWSP di campi personalizzati non sembra funzionare … qualcuno ha una soluzione?

Il mio problema è anche che desidero utilizzare dati di sessione specifici (ad es. Informazioni sull’utente) e voglio sapere quale hook è il migliore per questo, poiché plugins_loaded non vede l’utente

Grazie mille

Autore del plugin

(@awesomesupport)

2 anni, 10 mesi fa

@austriadesign – Ho testato entrambi i campi personalizzati creati con la funzione wpas_add_custom_field e che sembra funzionare per me. L’hook ancora utilizzato è plugins_loaded.

Per quanto ne so, il codice sembra andare bene.

Forse, solo per testare, rimuovere il condizionale if (function_exists (e vedere se questo aiuta.

Grazie.

Autore del plugin

(@awesomesupport)

2 anni, 10 mesi fa

Ciao:

Poiché non abbiamo avuto tue notizie su questo problema, presumeremo che sia stato risolto.

Grazie per aver utilizzato Awesome Support!

(@zanyojimbo)

2 anni, 10 mesi fa

Ciao, ho risolto i miei problemi collegando la funzione a “after_setup_theme” invece di “plugins_loaded” – questo probabilmente dipende dal tema che stai utilizzando. Spero che possa aiutare!

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *