Un utente ha chiesto informazioni su AMP di Wordpress

Impossibile far funzionare le pagine AMP

Un utente ha chiesto 👇

Impossibile far funzionare le pagine con amp. I lavori funzionano perfettamente. Amp è disegnato nelle impostazioni del plugin e nelle pagine (abilitato per amp)

Nella pagina del mio blog su: https://www.fidosysop.org/about-the-sysop/

Riferimenti a questo post: https://www.fidosysop.org/3657/03/amp-errors-and-cloudflare-incompatibility/

Su questo sito https://blog.ebaymotorssucks.com/internet-car-buying-selling-tips/amp/ retro pagina 404.

Questo sito viene utilizzato per testare: https://ms6790.xyz/dev/fwp/amp/ viene restituito anche l’errore 404.

Ho letto un altro thread simile che menzionava questo Yoast aveva bisogno di un amplificatore, ho un premio Yoast SEO e non riesco a trovare alcuna soluzione per un amplificatore.

Apprezzo il tuo aiuto per capirlo.

Questo argomento è stato modificato 3 anni, 1 mese fa da.

Autore del plugin

(@westonruter)

3 anni, 1 mese fa

Sembra che funzioni per me.

Dato l’URL canonico: https://www.fidosysop.org/about-the-sysop/

Guardando la fonte posso vedere che la versione AMP della pagina è confermata da:

<link rel="amphtml" href="https://www.fidosysop.org/about-the-sysop/?amp">

E vai a https://www.fidosysop.org/about-the-sysop/?amp la versione AMP viene visualizzata correttamente.

Sui motivi per cui le pagine AMP terminano con ?amp secondo /amp/, vedere https://wordpress.org/support/topic/0-6-0-not-working-for-pages/#post-9903766

Lanciatore di thread

(@fidosysop)

3 anni, 1 mese fa

Leggi quel post, ma come faccio a cambiare i miei permalink per aggiungere un amplificatore e cancellare / dopo la ringhiera? Amp / Il plugin non dovrebbe farlo automaticamente?

Autore del plugin

(@westonruter)

3 anni, 1 mese fa

Non sono sicuro di aver capito. Il tuo sito non sta tagliando ?amp.

Lanciatore di thread

(@fidosysop)

3 anni, 1 mese fa

Stavo usando un altro plug-in di amplificazione poiché questo non supportava le pagine. Sì, vedo che funziona con il permalink? Amp

Le pagine esistenti indicizzate da Google restituiscono 404 perché hanno indicizzato / amp /. Reindirizzerò le mie pagine con il richiamo e spero che goog aggiorni rapidamente il loro indice.

Grazie per l’aiuto.

(@ guardian88)

3 anni, 1 mese fa

Ho questa stessa domanda su tutti i miei siti. L’ampere viene disegnato ma non tutte le pagine, i prodotti ecc. Funzionano e Google non raccoglie l’ampere. Anche quando digito? Amp o / amp non viene fuori nulla e reindirizza alla pagina principale. Per favore aiuto.

Lanciatore di thread

(@fidosysop)

3 anni, 1 mese fa

Assicurati che le tue pagine abbiano un amplificatore. Dovrebbe funzionare bene. Crea referral se disponi di pagine amp attualmente indicizzate da Google.

Lanciatore di thread

(@fidosysop)

3 anni, 1 mese fa

Questo post contiene pagine Amp e referral abilitati https://www.fidosysop.org/7393/02/spammy-markup-google-webmasters-penalty/

(@ janey33)

2 anni, 10 mesi fa

Ciao,

Ho disegnato AMP su ogni pagina del mio sito Web e l’ho implementato (nelle impostazioni AMP e in ogni pagina). Ho guardato il codice sorgente e no

Autore del plugin

(@westonruter)

2 anni, 10 mesi fa

@ janey33 Inserisci l’URL del tuo post sul tuo sito dove ti aspetteresti AMP.

(@ janey33)

2 anni, 10 mesi fa

Ciao,

Non credo che funzionino su nessuna pagina del sito Web. Ho la stessa configurazione AMP su due siti Web e sembra che nessuno dei due funzioni.

Sto lanciando una pagina da ogni sito Web che sembra essere rappresentativa di tutte le pagine …

https://www.jgleamarketing.com/social-media-marketing/

http://www.jgleawebdesign.com/social-media-marketing/

Grazie

Autore del plugin

(@westonruter)

2 anni, 10 mesi fa

Vedi questo post: https://www.jgleamarketing.com/web-analytics/

Si noti che il file amphtml link alla versione e URL: https://www.jgleamarketing.com/web-analytics/amp/

L’URL https://www.jgleamarketing.com/social-media-marketing/ È per la pagina, quindi dovrai abilitare il supporto della pagina nelle impostazioni AMP generali.

(@ janey33)

2 anni, 10 mesi fa

Ciao,

Grazie – Ho abilitato le pagine nelle impostazioni AMP nel pannello e nelle singole pagine. Sapevo che i post funzionavano, ma le pagine non lo sono anche se tutte le impostazioni sono configurate per loro.

Autore del plugin

(@westonruter)

2 anni, 10 mesi fa

@ janey33 Sembra che tu abbia riscontrato lo stesso problema con la risoluzione dei problemi (non riuscita) su https://wordpress.org/support/topic/doesnt-works-with-pages-and-custom-post-types/

Ti suggerisco di cercare qualche consiglio su dove disinfettare.

(@ janey33)

2 anni, 10 mesi fa

Va bene – guarderò attraverso – Grazie!

(@z_atk)

2 anni, 9 mesi fa

@fidosysop la tua correzione del permalink ha funzionato a meraviglia, dato che il mio sito aveva solo poche pagine. Spero che questo non influisca sui siti di e-commerce!

Was this helpful?

0 / 0

Lascia un commento 0

Your email address will not be published. Required fields are marked *